BETA

7th January 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [07/01/19 01:21 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [07/01/19 01:28 PM]