BETA

17th November 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [17/11/19 04:54 AM] with 'Partial Outage'

Issue has been resolved at [17/11/19 05:24 AM]