BETA

16th November 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [16/11/19 08:35 AM] with 'Major Outage'

Issue has been resolved at [16/11/19 08:44 AM]