BETA

15th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [15/11/19 10:14 AM] with 'Partial Outage'

Issue has been resolved at [15/11/19 11:35 AM]