BETA

13th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [13/11/19 03:05 PM] with 'Partial Outage'

Issue has been resolved at [13/11/19 03:14 PM]