BETA

11th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [11/05/17 02:47 PM] with 'Partial Outage'

Issue has been resolved at [11/05/17 02:48 PM]