BETA

13th November 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [13/11/19 02:14 PM] with 'Major Outage'

Issue has been resolved at [13/11/19 02:15 PM]