BETA

13th November 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/11/19 01:14 PM] with 'Major Outage'

Issue has been resolved at [13/11/19 01:24 PM]