BETA

13th November 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [13/11/19 12:55 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/11/19 01:24 PM]