BETA

13th November 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [13/11/19 12:14 PM] with 'Partial Outage'

Issue has been resolved at [13/11/19 12:24 PM]