BETA

13th November 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [13/11/19 11:34 AM] with 'Partial Outage'

Issue has been resolved at [13/11/19 11:55 AM]