BETA

13th November 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/11/19 11:34 AM] with 'Major Outage'

Issue has been resolved at [13/11/19 11:35 AM]