BETA

13th November 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/11/19 11:25 AM] with 'Major Outage'

Issue has been resolved at [13/11/19 11:44 AM]