BETA

13th November 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [13/11/19 11:24 AM] with 'Partial Outage'

Issue has been resolved at [13/11/19 11:34 AM]