BETA

13th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [13/11/19 10:45 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/11/19 12:25 PM]