BETA

13th November 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/11/19 10:44 AM] with 'Major Outage'

Issue has been resolved at [13/11/19 10:54 AM]