BETA

13th November 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/11/19 10:44 AM] with 'Major Outage'

Issue has been resolved at [13/11/19 12:15 PM]