BETA

12th November 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [12/11/19 01:54 PM] with 'Major Outage'

Issue has been resolved at [12/11/19 01:55 PM]