BETA

7th November 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [07/11/19 02:24 AM] with 'Major Outage'

Issue has been resolved at [07/11/19 02:34 AM]