BETA

5th January 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [05/01/19 05:49 PM] with 'Major Outage'

Issue has been resolved at [05/01/19 05:53 PM]