BETA

7th November 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [07/11/19 01:34 AM] with 'Major Outage'

Issue has been resolved at [07/11/19 02:04 AM]