BETA

5th November 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/11/19 01:15 PM] with 'Major Outage'

Issue has been resolved at [05/11/19 01:24 PM]