BETA

31st October 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [31/10/19 02:04 PM] with 'Partial Outage'

Issue has been resolved at [31/10/19 02:14 PM]