BETA

3rd January 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [03/01/19 10:28 AM] with 'Major Outage'

Issue has been resolved at [03/01/19 10:36 AM]