BETA

31st October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [31/10/19 09:15 AM] with 'Major Outage'

Issue has been resolved at [31/10/19 09:24 AM]