BETA

31st October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [31/10/19 12:54 AM] with 'Partial Outage'

Issue has been resolved at [31/10/19 01:24 AM]