BETA

29th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [29/10/19 07:15 PM] with 'Major Outage'

Issue has been resolved at [29/10/19 07:34 PM]