BETA

28th October 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [28/10/19 08:44 PM] with 'Partial Outage'

Issue has been resolved at [28/10/19 08:54 PM]