BETA

28th October 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [28/10/19 07:24 PM] with 'Major Outage'

Issue has been resolved at [28/10/19 07:34 PM]