BETA

25th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [25/10/19 02:25 PM] with 'Partial Outage'

Issue has been resolved at [25/10/19 02:34 PM]