BETA

24th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [24/10/19 01:44 PM] with 'Major Outage'

Issue has been resolved at [24/10/19 01:45 PM]