BETA

24th October 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [24/10/19 12:54 PM] with 'Major Outage'

Issue has been resolved at [24/10/19 01:15 PM]