BETA

16th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [16/03/19 02:08 AM] with 'Partial Outage'

Issue has been resolved at [16/03/19 02:09 AM]