BETA

23rd October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/10/19 03:44 PM] with 'Partial Outage'

Issue has been resolved at [23/10/19 03:54 PM]