BETA

23rd October 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [23/10/19 02:34 PM] with 'Partial Outage'

Issue has been resolved at [23/10/19 03:04 PM]