BETA

23rd October 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [23/10/19 02:24 PM] with 'Partial Outage'

Issue has been resolved at [23/10/19 02:44 PM]