BETA

23rd October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [23/10/19 12:35 PM] with 'Major Outage'

Issue has been resolved at [23/10/19 12:44 PM]