BETA

10th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [10/05/17 12:08 PM] with 'Partial Outage'

Issue has been resolved at [10/05/17 12:09 PM]