BETA

23rd October 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [23/10/19 11:44 AM] with 'Partial Outage'

Issue has been resolved at [23/10/19 12:14 PM]