BETA

23rd October 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [23/10/19 11:04 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/10/19 12:04 PM]