BETA

23rd October 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [23/10/19 11:04 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/10/19 02:14 PM]