BETA

3rd January 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [02/01/19 06:57 PM] with 'Major Outage'

Issue has been resolved at [02/01/19 07:06 PM]