BETA

23rd October 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [23/10/19 10:24 AM] with 'Major Outage'

Issue has been resolved at [23/10/19 03:05 PM]