BETA

23rd October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/10/19 10:15 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/10/19 03:14 PM]