BETA

10th May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [10/05/17 11:02 AM] with 'Partial Outage'

Issue has been resolved at [10/05/17 11:03 AM]