BETA

23rd October 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/10/19 09:34 AM] with 'Major Outage'

Issue has been resolved at [23/10/19 03:04 PM]