BETA

23rd October 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [23/10/19 09:25 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/10/19 03:05 PM]