BETA

23rd October 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [23/10/19 09:24 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/10/19 03:05 PM]