BETA

23rd October 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/10/19 06:14 AM] with 'Partial Outage'

Issue has been resolved at [23/10/19 06:24 AM]