BETA

22nd October 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [22/10/19 02:34 PM] with 'Major Outage'

Issue has been resolved at [22/10/19 02:44 PM]